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ShipWeight Training Manual for 2019 
 

Chapter Comment 
ShipWeight Overview  
Customizing the ShipWeight System Database No need to customize the WBS if you want to 

use one of the standard WBS systems 
Starting a New Project See video 1 & 2 
Customizing ShipWeight Project Options See video 1 & 2 
Setting Up Codes and Item Settings See video 3 & 4 
Enter Weight Data Manually See video 3 
Import of Weight Data See video 4 
Filtering, sorting and Change Data See video 7 
Getting Results and Output See video 9 
Quality Assurance See video 15 
Playground Area See vide 10 & 11 
Parametric Estimation See video 12 
Loading Conditions and Hydrostatics See video 17 & 18 
Phase Codes See video 13 
Permission Settings See video 21 
ShipWeight Plugins See video  
Crystal Reports Only if student have Crystal Reports designer 

tool and wants to make own templates 
 

All videos found on www.shipweight.com in the “Videos” section 

See proposed agenda on next page. 

  

http://www.shipweight.com/
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Proposed Agenda 
Day 1 

• ShipWeight overview 
o Technical overview of system and databases  

• Customizing ShipWeight System Database 
o How to Create and Edit Work Breakdown Structure 
o Create Project Type Structure 
o Create Own Parameters 
o Create Parameter Views 

• Starting a new project 
o Creating a new project from scratch, enter main parameters 
o Project administration functions; open, save, save as, delete.  Project organization in 

folder structure. 
• Customizing ShipWeight Project Options 

o Change labels, decimals and units 
o Change Main Window fields/columns 
o Set Project Properties 

• Setting up custom codes and item settings   
o Define Custom Codes 
o Define Item Settings 

Day 2 
• Enter weight data manually 

o Navigating in the weight work breakdown structure (WBS), understanding the item 
window and its relation to the WBS. 

o Item History , deleted items 
o Manual input of weight data, related information, and learning about the quantity 

fields and their settings. 
• Import of data 

o How to import from Excel.  Looking at various ways of importing into ShipWeight.  
Understanding the basic import settings in the Data File Import window. 

• Retrieving specific data in ShipWeight 
o Filtering of the ShipWeight data, simple and advanced filters.  Finding a specific 

weight item.  Learning how to use wild card.  Storing filters. 
o Sorting of data in ShipWeight.  Sanity check using sort. 
o Change values for multiple rows at once.  Execute calculations on data in 

ShipWeight. 
o UnitWeight library using custom codes 
o Item Server library 

• Getting Results and Output 
o Getting summaries and grouping Weight and CG. 
o Make, check and export a weight distribution curve.   
o Calculation of moment of inertia and radius of gyration 
o Exporting data and make project backups 
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o Run simple Reports 
• Quality Assurance 

o Find duplicate items and check for extreme values 
o Compare Weight Group levels 
o Run a Code Definition Check via Code Envelopes 

Day 3 
• Playground Area 

o Setting up a sandbox environment in ShipWeight, moving weight items into the 
playground area and back to the live database 

o Using the playground area as a net change log and approval tool 
• Export to historical database 

o Learning the difference between a project and a historical vessel.  Preparing a 
project for export to the historical database.  Treating of remainders 

o Exporting to the historical database. 
• Parametric Estimation in ShipWeight 

o Learning about parametric estimation 
o Creating your estimation methods 
o Standard deviation and uncertainty handling in ShipWeight 
o Estimation of “local” CG 
o Going from parametric estimation to follow-up 

Day 4 
• Loading Conditions 

o Loading Conditions using Loading Condition Window 
o Getting Hydrostatic Calculated 
o Defining Loading Conditions using Global Filters 

• Phase Codes 
o Learn about the use of Phase Codes in ShipWeight 

• Administration tasks in ShipWeight 
o Setting up users and user groups, giving permissions to users 

• ShipWeight Plugins 
o Navisworks Plugin  

• Performance issues 
o How to optimize speed and performance when working on large databases and/or 

slow networks 

Day 5 
• Reports in ShipWeight 

o Crystal Report in ShipWeight, how to create your own Reports 
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ShipWeight Overview 
Technical and System overview 
ShipWeight is a client-server application where the application runs local on your local machine, 
while the data is stored on a central SQL Server and shared between all users.  Any number of client 
machines can access the same data, and users can work simultaneously on the same data.  
ShipWeight has at least 5 different databases in use.  Some data is project related and some data is 
shared between all projects.  This is outlined below. 

 

1. The SWSystem database holds system data that is shared among all projects.  This is where 
work breakdownstructures, parameters, methods, and similar system data is stored.  There 
can only be one SWSystem database, but it may contain several system.  A change to a 
system in this database will apply to all projects relating to this system. 
 

2. The SWLogin database stores all ShipWeight users and user groups and information about 
the permissions given to the groups and users assigned to the groups.  There can be only 
one SWLogin database. 
 

3. The sdb_ShipDB database holds the historical weight data from previous projects and this is 
the data that is used for the regression curve in the parametric estimation.  There can be 
more than one historical database, but usually there is only one. 

4. The project database holds the project data.  A project database can store several projects, 
but you can also have several project databases.  The project databases always starts with 
SW followed by a number (the number specifies the system relation). 
 

5. Project databases always comes in pair, where the primary project database has a secondary 
database with the same name, but ending with _Log.  This secondary log database stores all 
new entries, but also all changes and deletions. 
 



9 
 

The Work Break Down Structure 
The work breakdown structure (WBS) is the main coding structure in ShipWeight and has its main 
function in that all items must be assigned to a WBS group and the combination of the WBS group 
and ItemNo is what uniquely identifies a weight item. 

All parametric estimation is done according to the work breakdown structure, and thus the methods 
for the parametric estimation is related to the WBS weight groups.  This means further that to be 
able to exploit historical projects it means that the WBS must be shared between projects. 

To summarize: 

• All weight items must be assigned to a WBS group 
• The WBS coding must be shared between projects for estimation purposes. 
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Customizing the ShipWeight System Database 
In this session we will show step by step how to: 

o Create and Edit Work Breakdown Structure 
o Create Project Type Structure 
o Create Own Parameters 
o Create Parameter Views 

Step 1: Prepare an Excel Sheet with your WBS 
We need to start out with preparing an Excel Sheet that has the following columns: 

• SystemID – this is the name of the system you want to create and should be same for all 
rows in the Excel 

• PostID – this column will hold the ID of the various weight groups 
• Description – this column holds the description of the weight group 
• PostOver – this column should have the ID of the parent group 
• Sort (optional) – used to add numbers to force a specific order within a level.  If not used, 

the groups will be sorted alpanumerical. 
• Icon (optional) – used to add a number to specify a specific icon to be related to the group. 

Some special considerations: 

• The topnode needs to have PostID set to DISP (unless otherwise specified in the system 
setup window, see later in this document) and should have a blank field for the PostOver 
column. 

• Every level of weight groups that is supposed to be used for parametric estimation (often all 
without loads and reserve groups), should have a “Remainder” group as the last group in 
that level.  A remainder group has a PostID that ends with the letter “R”. 

The below shows a small sample of a prepared SWBS in Excel. 
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Step 2: Start ShipWeight and Log on 
Start ShipWeight and log in to ShipWeight using the user name “Administrator” and password 
“admin”.  

The system will be default be set to “Standard”. 
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Step 3: Open up the System Database Creation window 
Open up the System Database window by go to the menu Database->Administrator->System 
Databases… 
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Step 4: Make a copy of one of the existing WBS structures: 
Select the row named “Standard” in the System Database window and then click on the “Copy” 
button. 

 

 

Type in the ID for the new system you want to make in the pop-up window.  Note that this ID will 
have to be the same as the one you have in the SystemID column in the spreadsheet. 

Then click OK. 
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Step 5: Edit the new WBS structure 
A new line will now appear in the System Database window, with the new system ID.  This is now a 
copy of the standard system.  We will now edit this to make it into the new system.  Select the new 
line and click the “Edit” button as shown on next page. 

 

A window with the system database tables will show up.  Here select the “POST” table by selecting it 
from the droplist in the lower left corner of this window.  Next, select the small square at the upper 
left corner of the table to select all rows (our right-click in the table and select “Select all” from the 
submenu). 

Hit the “Delete” button to delete all rows in this table. 
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Now, copy the table from you Excel sheet with the work breakdown structure and paste it into the 
now empty “POST” table in this view (do not copy headers). 
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Finally, select the “POST_MAINMET” table, select all rows in this table and delete them. 

 

Repeat the same (delete rows) also for the “POST_MET” table.  Then close this window. 

Step 5: Restart ShipWeight with the new Structure 
Now you are read to also close the System Database window and also close down ShipWeight 
(menu: Project->Exit) and restart ShipWeight with your new system. 

When you restart ShipWeight, select your new system from the “System” droplist in the Login 
window.  Log on with username “Administrator” and password “admin”. 
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Step 6: Make any necessary changes to the new WBS 
If you need to make any changes to the weight groups in the new WBS, this can now be done from 
the Database->Administrator-Wgt. Grp. Definition… menu. 

 

This will open a window displaying the new WBS> 
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In the window you can use the treeview to the left to navigate and select nodes in the WBS, then 
alter values for the corresponding group in the grid to the right. 

Note:  You can also add a new weight group by adding the weight group information in the last row 
(marked with a *).  If you do this, make sure you move to the next row (or another row in the grid) 
after the information has been entered before you close the window. 

Step 7: Open the Project Types window 
Open up the Project Type window by going to menu Database->Administrator.>Project Type 
Definition… 
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There are two types of project types: 

• Main Type 
• Sub Type 

You can add a Sub Type to an existing Main Type, or you can add a new Main Type to hold new Sub 
Types. 

Main Type and Sub Types have a numeric ID and a name.  Then ID of a Main Type can be anything 
from 0 to 99 as long as it is not taken by an existing Main Type.  The Sub Type ID will be the ID of the 
Main Type + anything from 00 to 99. 

This means that if 10 Main Types exists (Main Types are the top nodes in the treeview to the left ) a 
new Main Type entered would then have 11 entered in the “ID” column, a name entered in the 
“Name” column, and a blank entry in the “Parent” column. 

Sub Type of this new Main Type, would then have IDs 1100, 1101, 1102, etc and the “Parent” 
column should be set to 11. 

 

When you add new line to the list, after entering information into the cells, click the next cell above 
to make the list update itself, then scroll to the bottom to see a new line ready for a new entry. 

Step 8: Create the new Parameters 
In ShipWeight main window, go to menu Database->Administrator->Parameter Definiton… 

In the Parameter Definition window that opens, scroll to the end of the list, right-click the list and 
select “Insert”.  These parameters will be available for all projects. 
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In the new line that appears, click once in the first grid (may take a sec. before it becomes active) in 
the column ID and when it becomes editable, type in arcRHO as ID. 

 

Click the tabkey to go to the next column (Name) and fill in Seawater density.  Continue for the next 
columns and set Type to decimal, Decimals to 4 (or 3 if you prefer), unit to t/m3 and Symbol to Rho. 
Finally set Max to 2 (max allowed input). 

The end result should be like this: 
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Once again, right-click the list and click “Insert” and add the Prop. Power parameter, name the ID 
arcPP and fill in the appropriate column values.  Repeat for Class, Auxiliary Power, and Interior area.  
The input may be something like this (you may alter all values here except for the ID – the ID is 
referred in the report and must be the same as in this document: 

ID Name Type Decimals Unit Symbol Max 
arcRHO Seawater density Decimal 4 t/m3 Rho 2 
arcPP Propulsion power Integer 0 kW P 1000000 
arcCl Class Text 0 - C 0 
arcAD Auxiliary Power Integer 0 kW P 1000000 
arcIA Interior area Integer 0 M3 A 1000000 

 

The end result should look something like this: 

 

Next click “OK” and answer “Yes” to pop-up asking to reload new parameters. 

Step 9: Make Custom Parameter View for New Parameters 
This step is strictly speaking not necessary per se, but it will make it more convenient to find and fill 
in these parameters.  As with the parameters themselves, the parameter view you make here will be 
available for all projects. 

Start by going to menu View->Parameters…   In the Parameters windows, right-click and select 
“Parameter View Settings…”: 
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In the Parameter View Setting window, right-click again and select “Add View” 

 

Type in “Arctech” (or whatever you like really) as name of the new View in the grid that appears.  
Right-click again and select Add Group in the menu.  Give in the name “Report parameters” (or 
something) as name of the group. 
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Next, right-click in the Parameter list in this view and select “Search”. 

 

 

Start to type in “Sea” in the search window to find the Seawater density parameter, select it in the 
list below and click “OK”. 
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Now select the “Seawater” parameter in the list and “drag and drop” it with the mouse into the 
Report Parameter group. 

 

Repeat for the other parameters.  End result should look like this: 

 

Note: On some computers we have a bug reported that the entire list of parameters to the right 
turns blue.  This is an inconvenience that we are working to fix, however, it does not prohibit to use 
this function, everything works - it is mere an esthetic issue.  If you experience this we apologize for 
the inconvenience. 
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Close the all windows and reopen the parameter window and you should find your new view with 
the parameter.  Make sure the “Defined only” box is unchecked – or else you will not see the 
parameters.  Defined only means only parameter that already have values attached. 

 

 

Fill in the parameter values in the new tabsheet. 
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Starting a new project 
In this session we will see how to: 

• Creating a new project from scratch, enter main parameters 
• Project administration functions; open, save, save as, delete.   
• Project organization in folder structure. 

Step 1: Start ShipWeight 
Double-click the ShipWeight icon from your desktop to launch the program. The first thing that pops 
up is the Login window: 

 

 

Make sure to select Windows as Authentication method and leave the SQL Server to default. The 
User Name is not your Windows user name, but is your ShipWeight user name. Fill in the 
corresponding Password.  

The System droplist should bet set to the default value. Open Last Project check box should not be 
checked. Click OK button to launch ShipWeight. 

ShipWeight window will open, with no project loaded: 
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Step 2: Start a new project 

Go to the Project menu and select New or go to the toolbar and click the new button  

The Project info window pops up: 

 

There is two mandatory fields in the Project info window that needs to be filled out: 

The project Database ID* is the place where to store the new project, so you can select an already 
existing database from the dropdown list or type in a new database id. For this tutorial, please select 
ProjectDB  
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The Project ID* is the id of your project, and the user can type anything as long as it is unique. For 
this tutorial, please type Tutorial 

 

Name field: MS Breeze 

Main Type field: select Offshore Vessel from the dropdown list 

Type field: select Anchor Handling Tug from the dropdown list 

The Frame Spacing field: is a bit important because this will allow to include frame spacing in the 
input and use frame spacing instead of position, when the user enters the position for location of an 
item in the X direction.  

Example:  - for frame spacing of 0.65 meters, simply type 0.65# 

                 - for dynamic frame spacing, type for example 0.65#25;0.7#90;0.6# 

                    The tooltip here will show an example of the coding for this dynamic   

                    frame spacing:  

                    

 

For more information, press the F1 keyboard button, which will launch the Context-sensitive Help 
File: 
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Units field: keep the Metric units 

 

Click OK and the new project will start.  

 

Now, the user will be asked to choose the main weight group for the new project. In this case keep 
the DISP Displacement selection and then press OK.  

The next window that pops up is the Parameters window: 
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Expand the window and enter the main parameters that are currently available for the project: 
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Notice that some of the parameters have a green icon to the right of the Value cell. For example the 
Block-coefficient. If the user knows the block-coefficient value, he can just type in directly. 

If the block-coefficient is unknown, the green icon will open the Composite Parameter window, 
which will allow the user to enter other parameters to help calculate the block-coefficient value. 
Input 7700 for Displacement [t] field, and then let the rest of the parameters as they are. The Block-
coefficient will instantly be calculated: 
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Press the Close button. 

 

 

Now click OK to close this window. 

The Project Info can be found on the top right side of ShipWeight window and the Parameters info 
on the lower right side. The information can be changed anytime when working with the project, by 
clicking on the Project Info and on the Parameters headers. 



33 
 

 

 

 

Step 2: Open and Save a Project Copy  
Start again ShipWeight and login: 

 

to open up the main window: 
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Right now ShipWeight opens without any project loaded into the main window. To load a project 
into the main window you can either open a project from the menu, going on Project -> Open or you 

can go to the toolbar and find the Open Project button . Either way you choose, the Open 
Project window will pop up: 

 

The upper part shows the name of the Server, which usually stays the same, you rarely change the 
server name. 

The next part will show the Database, the project databases that are on your server. You need to 
have at least one project Database. Each project database can contain any number of projects. 

Now click on the lower part of the project Database, for example click on SW00_ProjectDB. You will 
see in the lower part of the Project ID all the existing projects from the selected Database: 
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Now, select from the Project ID list the Tutorial project and then click OK to open up this project, 
and then after few seconds the project is loaded into ShipWeight: 

 

To make a copy of this project, go to Project menu, then select Save As… 

Choose the Database you want to save it in (ProjectDB) and then type the Project ID to be used for 
the copy of the existing project: 
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Now hit the OK button and a copy of Tutorial project is stored as Tutorial_Rev1. 

To get back to Tutorial project, you can open it from the Open window, but also on the project menu 
there are some shortcuts that shows the last four projects: 

 

This is how you can open and save projects on ShipWeight. 

Step 3: Setting up a Catalogue Level in ShipWeight 
In ShipWeight 13 a catalogue level is introduced to make it easier to organize project.  
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Open the “Open Project” windowue (from menu Project->Open…) and select the Browse […] button 
marked in red in the picture below.

 

 

Select a database, right-click to select “New Folder” and type in a folder name of your choice.
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Continue in the same manner to create more folders and subfolders until you have the desired 
catalogue structure.  

 

Move and organize projects into folders by selecting project IDs and “drag and drop” with the mouse 
into appropriate folder.
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Select a project and click the “OK” button.  Your project should now appear (and be selected) with 
the catalogue structure made for the projects in the database.  Repeat for other databases. 

 

Step 4: Deleting a Project 
To delete a project, navigate to Project menu, select Delete, then Delete Project: 

 

The Delete project… window will appear, which contains the same, the Server, Database and Project 
ID. 
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Select the Database SW00_ProjectDB, and the Project ID Tutorial_Rev1: 

 

Click OK to delete it. 
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The Extra “Save As…” Options 

 

 

• “Copy Log” – check this to copy the log data from the existing project and to the new one 
• “Copy Permissions”- if this box is checked, the permission settings for user-groups for this 

project should be copied to the new project so there is no need to set new permissions. 
• “Freeze current”  should set all user-groups to be “Read-only” in the project you are saving 

from. 
• “Delete workset” – when you start a new revision and you want to start with a clean set of 

worksets.   
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Customizing ShipWeight Project Options 
This session will show how to: 

• Change labels, decimals and units 
• Set Project Properties 
• Change Main Window fields/columns 

Step 1: Open the Options window 
To open the Options window go into the View menu, and select Options… 

 

This will bring up a window that has many tab-sheets, and in each sheet, you can set various options: 

Step 2: Set Units and Startup Parameters 

 

The first sheet is General, where you can select: 
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• Units in Metric or US 
• The Weight Unit 
• Whether it should summarize at startup etc. 

Note especially the “Weight field” droplist.  This is where you select the weight field to be 
summarized in the main window.  By default, it is the standard weight field, but you can  

 

Step 3: Set Number of Decimals and Mass Properties Labels 
The next tab is the Decimals settings, for the weight groups in the main window and for the detailed 
items in the Item window: 

 

Step 4: Set Quantity Properties 
Next you have names for Quantity and default settings for Quantities when a new row is added: 
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Refer to the Help File for Extra Information about the settings 
For more details about this settings hit the F1 key to bring up the context sensitive help, which will 
show you explanations for various tabs of the Options window: 

 

Finally, in the Project Administration chapter, we will see how to navigate in the work breakdown 
structure.  
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Step 5:  Set which Fields to Show and Field Order in Main Window 
You can change the order of the column in the main window.  In version 12 you could turn visibility 
on and off by right clicking in the main window treeview and select “Show fields”.  You can now also 
rearrange the order by dragging and dropping the items in the list. 
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Setting Up Custom Codes and Item Settings 
This section will show how to: 

• Define Custom Codes 
• Define Item Settings 

Step 1: Open the Code Definition Window 
To open the Code Definition windw, select Code definition… on the View menu of ShipWeight 
window.  

 

 

The Code Definition window contains a tree-view on the left side, and a table on the right side. It 
allows the user to define his own fields in ShipWeight. 

Step 2: Define an Editbox Custom Code 
To create a code, select the cell in the column “CodeType” of the table. The cell will become 
activated and editable. A new row automatically will be added, and the cell will turn into a combo 
box (editable dropdown list). Next, activate the dropdown of the combo box and select the ID of the 
custom code you want to make e.g. C01. 
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Next, fill in the following fields: 

 

Field               Value                         Description                                                         

Title                Drawing no.               Title will show above field in Item dlg.  

Description     Drawing number        Information only, no effect  

FieldSize         20                               Number of characters allowed in field  

Calculate         (leave empty)             Formula for calculated codes (Leave empty)  

Align               Right                          Alignment of value in Item dlg.  

Format            (leave empty)              Formatting of calculated fields (Leave empty)  

FieldType        EditBox                      Specify a standard editable field  

 

To finish the registration of code C01, click with the mouse on the empty line in the table. You can 
make sure that the code has been registered by checking that it is added to the tree left of the grid. 
Click the minus/plus sign to (un)expand the tree. The FieldType in this case is EditBox. This means 
that the custom code field will be an editable box where the user may type in freely.  

The other Fieldtypes are:  

• ListBox – the user must select value for the field from a dropdown list of predefined values  

• ComboBox – the user may select value for the field from a dropdown list of predefined values or 
type in freely  
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• ReadOnly – the value cannot be changed by the user 

 

 

Step 3: Define a Listbox Custom Code 
In the same way, add the code C02 with the following values:  

Field                   Value                                                                             

Title                    Weight Status  

Description         Weight Status Code  

FieldSize             20  

Calculate             (leave empty)  

Align                   Left 

Format                (leave empty)  

FieldType            ListBox  

 

Next, we will add code values to the Weight Status code. In the tree-view, select code ‘C02 – Weight 
Status’. An empty table for adding code values will appear on the right side of the tree-view. 
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Select the row of the table and fill in these values:  

 

 

Field                             Value                                                                             

CodeID                         E  

Description                   Estimated  

Factor                           1.1  

 

Leave the rest of the fields empty, and click on the next row in the table. Enter two more code 
values:  

 

Field                             Value                                                                             

CodeID                         C  

Description                   Calculated  

Factor                           1.05  

 

Field                             Value                                                                             

CodeID                         W  

Description                   Weighed  

Factor                            1.02  
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Finish registering the code value by clicking the last row in the table with the mouse. 

 

Step 4: Define a Calculated Custom Code 
Next, click the topmost asterisk in the tree-view to display the Code Definition table. Add code C03 
with the following values:  

 

Field                           Value                                                                             

CodeType                   C03  

Title                            Weight with Margin  

Description                 Weight multiplied with margin based on Weight Status code  

FieldSize                     20  

Calculate                     [Weight]*[C02].[Factor]  

Align                           Right  

Format                         %.3f  

FieldType                    ReadOnly  

 

Click the empty row of the table to finish off the registration of C03.  
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Hit F1 button to bring up the Help file for Code definition window: 

 

 

In the Help file, select the Calculated Codes to find all the options to use for the calculated fields and 
how to set the calculations: 
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Finally, close the Code Definition window. 

Step 5: Check the Added Codes in the Item Window 
Open the Items window, in ShipWeight main window select Items and choose List Items -> All… 

Alternatively, press the ‘Item level’ button on the toolbar:  

The Items window now opens in default mode. In the Items view, it can be noticed all of the added 
codes: 
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The Code Definition window can be reopened anytime from Items window, View menu -> Code 
Definition. 

Step 6: Open the Item Setting Window 
In the Item Settings window the user will have the possibility to take these codes and move them to 
different positions of the Items view, and learn how to generalize and customize this view. 

In the Items window, select Item settings… in the Setting menu to display the Item setting window. 
Alternatively, press the Item setting… button on the toolbar. The Item setting window controls the 
layout of the Item window. 
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Step 7: Create A New Setting 
After the Item Setting window pops up, to start creating a new setting, press the New Setting 
button. This will generate the starting point for the new setting. 

In the tree-view on the left side, click the plus sign next to the asterisk to expand the tree. A setting 
named ‘New setting’ has been created. Your window should then look like this: 
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Step 8: Define the Settings 
Make sure the topmost asterisk is selected in the tree. Click the ‘New setting’ cell in the SettingID 
column of the table. Change the Setting ID from ‘New setting’ to e.g. ‘Default Setting’: 

 

Next, expand the tree further by clicking the plus sign in front of ‘Default Setting’, ‘Single view’, 
‘Weight & CoG’ and ‘Codes’. Select ‘C02’ in the ‘Codes’ branch of the tree: 

 

 

Using the mouse, drag ‘C02’ from the ‘Codes’ group and drop it on Weight in the ‘Weight & CoG’ 
group. C02 will now be placed directly after the Weight field in the Single Record area of the Item 
window: 
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Now go to Table view.  

 

Expand the ‘Table View’ branch by clicking the plus sign in front of it, and then the ‘Weight & CoG’ 
branch. Select ‘TCG_min’ with the mouse. Drag and drop it in the ‘Hidden’ group. Repeat this for 
TCG_max. 

The TCG_min and TCG_max fields will now be hidden in the Table View area of the Item window. 
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Step 9: Active the New Setting in the Item Window 
To activate the new setting ‘Default Setting’, close the Item Setting window, and then select ‘Default 
Setting’ from the ‘Setting’ dropdown list on the toolbar: 

 

 

Now, the Item window should look like this: 
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Based on the changes made in the Item Settings window, now it can be noticed that C02 code 
(Weight Status), is located in the Single View: Weight & CoG: 

 

Step 10: Make a Change to the Item Setting by Editing It 
To change the width of items in the Single View, open the Item Settings window, go to Single view, 
then Codes, and click on C01-Drawing no.  

 

Now change the standard C01 code Width from 100 to 300: 



59 
 

 

The result will be: 

 

As long as the Item Setting ‘Default Setting’ is selected in the drop list, any changes that the user will 
do to the ‘Item Setting’ window will automatically be applied to the ‘Items’ window. 
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Enter Weight Data Manually 
In this session: 

• Navigating in the main window 
• Manual input of weight data 
• Item History and Deleted Items 

Step 1: Open the Item Window 
There are three ways to open the item window: 

Select Items and choose List Items -> All 

 

Alternatively, press the ‘Item level’ button on the toolbar:  

 

Or select Items header on this preview window: 
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Choose one of the specified options to open the Items window: 

 

It is very important to know the link between the selected weight group in the main window and the 
actual item window that pops up. 

When the Items window was opened, the focus was on the SWBS group H – Hull, and this means 
that H is now opened in the item window. In the weight group filter we can see H: 
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To close the Items window press the Close window icon .In the lower part of the item window, in 
the highlighted area in yellow color, by pressing the arrow button, this will clear the fields of the 
single record view.  

This procedure is only necessary if there already are weight items defined in the weight group. 
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Step 2: Add a Weight Item in the Item Window via the “Single View” 
In the ShipWeight main window window, navigate to weight group H1.1 Aftbody and open the Item 
window. 

 

 

Add weight item ‘Section 1’ using the ‘Single Record’ area  

To register a new item weight using the Single Record area of the Item window, you must start by 
selecting Weight Group H1.1 from the WgtGrp dropdown list. 
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Jump to the ItemNo field by pressing the TAB button. Enter Item number 1. When pressing TAB once 
more, the item will be created. Continue filling in data for the weight item.  

 

Data for Section 1, H1.1 Aftbody:  

 

Field                           Value                                                                             

WgtGrp:                     H1.1  

ItemNo:                      1  

Description:               Section 1  

NoOff:                        1.000  

Factor:                        1.000  

Length:                       1.000  

Width:                        1.000  

UnitWeight:                66000.00  

 

Field                           Value                                

Weight Status:            C  
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VCG:                          4.300  

LCG:                          -1.250  

TCG:                           0.000  

VCG_min:                  1.500  

VCG_max:                 6.000  

LCG_min:                 -5.000  

LCG_max:                  2.500  

TCG_min:                   0 (hidden field)  

TCG_max:                  0 (hidden field)  

Drawing no.                123-456 

 

 

To complete the registration of the weight item, press the right-arrow on the toolbar, or click the 
empty row in the table. 

Step 2: Add a Weight Item in the Item Window via the “Table View” 
Select the empty row in the table and double click the WgtGrp cell. WgtGrp will now be set to H1.1. 
Click the TAB-key to jump to the next column. Continue entering item data for ‘Section 2’. 
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Data for Section 2, H1.1 Aftbody: 

 

Field                           Value                                

 

WgtGrp:                     H1.1  

ItemNo:                      2  

Description:               Section 2  

NoOff:                        1  

Factor:                        1  

Length:                       1  

Width:                        1  

UnitWeight:                73000  

VCG:                          4.2  

LCG:                           6.25  

TCG:                           0.000  
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VCG_min:                  1.5  

VCG_max:                 6.000  

LCG_min:                  2.500  

LCG_max:                  10  

Drawing no.                123-654 

Weight Status:            C  

Step 3: Make a Change to a Weight Item 
Make a change to an item by editing one or more values in fit the item. 

Step 4: Check Item History 
By right-clicking and selecting “Item history”, the user can see all the changes that have happened to 
the selected item. 

Now, it is possible to recover a previous version of the item by selecting a previous version of the 

item and click the “Recover button”. 

 

Step 5: Deleted Item History 
Now delete the item you changed.  Right click in Items window, select “Deleted Items…” to recover 
the deleted item. 
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 The Project Log Database window will open: 
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Import of Weight Data 
This session will give an introduction to the import of weight data from Excel. 

Step 1: Open the “Data File Import” Window 
IWe will import weight data from an Excel workbook. This can be done using the ‘ShipWeight Data 
File Import’ window.  

Open the Data File Import window from menu: Project -> Import -> Data file… 

 

Step 2: Browse and Select a Spreadsheet File 
First we browse and select the spreadsheet file. On the ‘Assistant’ tab-sheet, we press the Browse 
button. Using the ‘Open window window, we locate the Excel file to import. Press the Open button 
to select the file “Tutorial.xls”. 
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The Data File Import Window supports the import of XLSX files in addition to XLS files. Once the 
Excel File has been selected, a preview of the sheet included in the file will be shown.  

Step 3: Select the sheet in the Import 
Then, the next step is to select the sheet to import. 

 

When the sheet is selected, the import window will try to guess the mapping between the columns 
in the spreadsheet and ShipWeight fields, based on the column headings in the spreadsheet. 
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Columns where mapping have been found automatically will get a green colour and the mapping will 
be shown in the list below. If this mapping is wrong, you can deselect the column either in the sheet 
preview or in this list of linked columns.  

Step 4: Manually Add Any Missing Import Mapping 
To manually add columns not automatically mapped, click on the column either in the preview sheet 
or in the column list and select the corresponding ShipWeight field from the ShipWeight list.  

An import can be run directly from the ‘Import’ tabsheet (either to main database or to Playground 
area), or the mappings and settings can be transferred to the normal data file import for more 
advanced settings and checking. 
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This import definition list may be saved (click “Save” button in the window) and restored by clicking 
from the “Open” button later. 

Step 5: Check and Set Import Options 
Before we start importing data, we must set the import options. Click the ‘Options’ tab sheet. First 
we will keep the option ‘Auto ItemNo start’. The reason for this is that our spreadsheet doesn’t 
contain a column for item numbers.  

Please note that the import will fail if you try to import data with item numbers already in use in the 
database. If this is the case, please try to increase the number in the ‘Auto ItemNo start’ field.  

The ‘Pad ItemNo’ button will change the format of the item number of existing items. First set the 
number of characters the item number should include. Pressing the ‘‘Pad ItemNo’ button will add 
the digit 0 in front of the item number, so that the item number includes the proper number of 
characters. Please note that the option ‘Number of header rows’ is disabled. The ‘ShipWeight Data 
File Import’ always assumes that the spreadsheet contains one header row. 



73 
 

 

Now when the settings are ready we can choose either to Import or Test it. 

Step 5. Test the Import Prior to Importing It 
To test the import, first we go to the ‘Log and Test’ tab sheet: 

 

Select ‘Test SWI’ button to see if there are any errors detected in the import definition file. As we 
can see, right now there is no errors: 
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Then, we can also select the ‘Check import’ button, to perform the import without actually 
importing it. Now it runs throught the import and it will show you a small report, that the import is 
completed: 

 

Step 6: Carry Out the Import 
Now we are ready to start importing data. Make sure that the spreadsheet you are going to import is 
not open in Excel. 
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In the Import complete window press OK button. Then press Close button in the Import window. 
The Update Information window will appear, asking you to ‘Summarize wgt.grp.’ in the ‘Wgt.Grp’ 
menu.  

 

Click OK. 

Step 7: Update the Main Window 
Now, in the main window window of ShipWeight, go to Weight Groups menu and select ‘Summarize 
Wgt.grp’: 
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Filtering, Sorting and Changing Data in ShipWeight 
This section will look into how to 

• Filter data in ShipWeight 
• Sort data in ShipWeight 
• Change weight data and perform calculation on weight data for multiple rows 

Step 1: Open the Item Window 
In the tree-view on the main window, navigate to weight group E2.2 under LW – Lightship -> E – 
Equipment -> E2 – Ship equipment, and open the item window.  

Step 2: Open the Filter Window, Set and Save a Filter 
Press the ‘Apply filter’ button on the toolbar, or select Tools -> Filter -> Apply… on the Tools menu. 
The Item Filter window will pop up.  

 

In the ‘Table Fields’ list, select VCG. Select the ‘>’ operator from the ‘Operators’ list. Set the ‘Value’ 
to 4, and press the Insert button.  
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Note that you can save the filter by giving it a name in the “Filter name” droplist and then click the 
“Save” button.  All saved filters can be retrieved from the drolist in the Filter window and directly 
from the filter droplist of the Item window. 

 

Press OK to apply the filter. All items which have VCG’s larger than 4.0 meters will be listed.  
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To remove the filter, select Tools -> Filter -> Clear, or press the ‘Clear Filter’ button.  

More on Filter and “Wild cards” 
A “Wild card” can be used in a filter string the following way: 

Use % to represent any character and any number of character. 

Use _ to represent any character. 

Use [ ] to specify “either” of values presented in the square brackets. 

Use ^ to indicate NOT then followed by [ ] with the NOT characters inside the brackets. 

Step 4: Open the Sort Window 
To open the Sort window, select Sort -> Apply… on the Tools menu, or press the ‘Sort’ button on the 
toolbar.  

 

Click the ‘Field Name’ cell of the empty row. The cell will change to a combo box. Activate the 
dropdown list, and select Description. 
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Click the ‘Sort’ cell. By default, the value will be set to ‘Ascending’.  

On the next row, select Field Name: Weight. 

Data Type: Ascending  

 

Press the OK button to apply the Sort.  

 



81 
 

 
Step 5: Paste Values to Certain Columns 
This function will allow to specify which columns to paste to from the clipboard.  Pasting will happen 
to existing items and from the selected row and below (depending on how many rows are in the 
clipboard).  Picture below shows how to do this in the table: 
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Step 6. Duplicate Rows 
A function for easy duplication of a row into any number of copies.   

ItemNo can follow the copied one, adding on a suffix to the item 3136_1, 3136_2, 3136_3,… 

GUI shown here: 

 

 
 
  



83 
 

  
Step 7: Change Some Data Values by Calculation 
The “Execute operation” window that can be opened from the Item Window has changed name to 
“Change Field Values…” and has a new option allowing for much greater flexibility than the 
Add/Subtract/Multiply/Divide options in version 12. 

The new option “SQL Operation”, allows the user set a calculation formula to update a field.  The 
calculation formula may refer to other fields.  The simple example below shows setting LCG_max 
values for the selected items to the LCG value plus 1 meter (LCG +1).  Note that these expressions 
should always be set in SI/metric units, even if project is in imperial units. 

 

Step 8: Adding a Correction Weight to Adjust a Summary 
Sometimes you want to adjust a summary to make it a specific set of values.  As an example, you 
want to adjust the Lightship weight and center of gravity to match the results from a displacement 
and inclining test. 

ShipWeight has a function to let you automatically accomplish this.  First, right-click the weight 
group you want to adjust, and select “Correct Weight” in the submenu that appears. 
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In the “Add Correction” window that pops up, in row A; fill in the values (weight and CG) you want 
the summary  to have after correction. 
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In row B, make sure it displays the correct summary that you want to change.  If not correct, click the 
cell to change the to the correct weight group from the droplist. 

In row D, ShipWeight is suggesting to add the correction to the remainder group.  If you want the 
correction to be added to a different weight group, change this here by clicking the cell and select 
the desired weight group from the droplist. 

 

Next, still in row D, set if all or only parts of the correction should be applied to the selected group in 
row D.  The default is 100 % - that the full correction will be applied to the group.  Click “Apply” 
button to transfer the calculated values to the main window. 

 

The main window is now updated with the corrected weight. 
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Step 9:  Create a UnitWeight Library 
Create a custom code for the library (call it what you want).  Make it a Combobox or a Listbox 

 

Fill the custom code with codes representing the library, remember you can to copy/paste from 
Excel 

 



87 
 

In the Options dialog (menu: View->Options in main window), go to the “Item” tabsheet and 
select your UnitWeight source. 

 

Add your new item code to any Item Settings that have been made prior to the custom code. 

Step 10: Create an Item Library. 
Create a special project where you add equipment to the various weight groups. 

In the project you want to import, go to the Item Window with the item weights, go to menu 
View->Items on Server…   
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In the Items on Server window, select the library project (Feadship in this example), do any 
filtering needed to find the equipment (see Description filter example here), select the item in 
the list of item, rightclick and select “Import item”. 
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Getting Results and Output 
In this section the following will be shown: 

• Making the Weight Distribution Curve 
• Calculation of Inertia and Radius of Gyration 

 

Step 1: Open a Project with Weight Data 
Open a previous project that has weight data. 

Step 2: Check the LCG_min and LCG_max Values 
To get a good distribution curve it is a big advantage if you have the starting point and ending point 
of your weight items. Basically you should have the LCG, and the LCG_min, LCG_max values for each 
item to get a good weight distribution curve. 

 

Step 3: Set Default Extent for Items without Extent Data 
However if there are some items who do not have extensions, default extensions can be set to be 
used for those. To do this go to View menu and select Options: 
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The Options window will pop up: 

 

Change the default Extent from 0 to 2 and min. from 0.01 to 0.5 meters: 
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And then click OK. 

Step 4: Open the Weight Distribution Window 
Now, to open the weight distribution window go to View menu, and select Weight Distribution…: 

 

Or the shortcut from the toolbar . 

Then the Weight Distribution is opened for the vessel: 
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By default we are looking at Accurate weight distribution curve type, and to see the data behind the 
curve you can enable the plotting of the Weights option: 

 

Step 5: Check the Weight Data 
The center of gravity location for each weight in the database is plotted. The black dots represent 
the steel weights, the green dots for equipment weights, and the red dots for machinery weights. 

To check the weight data for any dot, click and hold on the specific dot: 
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In this way you an check suspicious looking items. If you find some items which are not correct, the 
double click on the point and it will bring up the Items window, and finds that item for you and 
allows you to change that item: 

 

Step 6. Transform the Curve to a Given Number of Stations  
Now in addition to get this accurate curve, you can also select Stations curve type and type in 20 
stations curve: 
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You can also do Individual stations curve type, and by typing the numbers and points 0;20;30 where 
you want to see the various stations: 

 

Step 7: Create a SAWE Curve (Individual Stations) 
You can also right click and select Create SAWE stations: 
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Which will be default give 20 stations between AP and FP and then 1 station in front of FP and 1 
station behind the AP: 

 

In addition, there is also the Item Filter, can be opened from the Item filter   browse button in 
the lower left corner of the Weight distribution window: 
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And you can set any filter you want, WgtGrp, ItemNo, Description, etc.  

Step 8: Export the Curve to a Stability Software Format 
If everything looks ok with the curve, you can go and export the weight distribution curve by using 
the Print/Export button: 

 

The Print/Export Distribution Setup window pops up and you can select the desired Format to get 
formats that are suitable for import to this stability software for doing longitudinal strength 
calculations: 
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Step 9: Check the Curve in Other Directions 
Finally, the user should know that not only the longitudinal extent (X-Z dir.), but also other directions 
to look at the curve are available. For example in the Y-Z direction, go to the tab sheet Y-Z dir., and it 
will show the distribution curve over the beam of the vessel: 

 

Step 10: Calculate Moment of Inertia and Gyradius 
Open the Gyradius Window from the menu View->Gyradius… 
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This brings up calculation for gyradius and moment of inertia for the vessel: 

 

Step 11: Apply Any Necessary Filters 
Here we can apply Item filters: 
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Step 12: Get the Main Moment of Inertia and Gyradius 
Now it is calculating Moment of Inertia and Gyradius values for Roll, Pitch, Yaw, and also for the 
product of inertia Pitch/Yaw, Roll/Yaw, Roll/Pitch: 

 

Here you can find details for each individual item: 
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The way ShipWeight is calculating: 

The Moment of Inertia by taking the Transverse inertia using the Steiner’s theorem or parallel axis 
theory and that it’s done for all items. If there is an item that has extents in all three directions then 
the item will be approximated to a box and also calculate the local inertia for that particular item. 

It is also possible to point to custom codes which can have exact values for the moment of inertia 
stored in the custom codes if you can get such values from the CAD software. 

 

Finally, if the GM values for transverse and longitudinal are known from the stability software. So 
let’s type in some values: 
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Step 13: Calculate the Oscillation Period 
Also based on this we can calculate the Oscillation period (T): 

 

Step 14: Export Data to Excel and/or text files 
Export is done in the same window as the “Import Data Window”, but by selecting the tabs “Export” 
and “Export Excel”.   Proper settings must be set for the export options and a saved mapping must 
be used to define the export. 
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If you do not have a saved mapping, the mapping must be created manually.  This is how to to it: 

 

Steps (see numbers in red in picture): 
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1. Go to Import tabsheet 
2. Select the first column you want to export in the droplist 
3. Click the Add button to add to export mapping.  Repeat step 2 until all columns you want to 

export has been selected. 
4. If you want to change the order of columns, select a row in 5 and use buttons Move up and 

Move down as needed (only if you need to change order) 
5. This displays your export columns. 
6. If you want to you can save the mapping by pushing button Save (not necessary to do the 

export) 
7. If you have already saved a mapping, you can open it from this button. 

This method of export is the fastest and should be used if you have many thousand items to export.  
If the number of items are not so many, you may use alternative method, see next page: 

Alternative method if number of items is not too many: 

Export from the Item Window in ShipWeight, menu Items->Import/Export->Export Excel, see picture 
below. 

This will export the items in the table view in the Item Window. 

 

 

Step 15: Create Backups of Your Projects 
Create a text file backup of a single project by going to the menu Project->Export->Project (text file). 
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You can restore the file by going to the corresponding menu item in the Project->Import menu, 

Backup and restore of the complete database can be done by going to the menu “Project->Backup”.  
Note that this backup will only work if you have backup permissions on the SQL Server. 
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Quality assurance (QA) – Compare and Vetting Projects 
Below, the following QA methods will be shown: 

• Find duplicate weight items 
• Checking for extreme values 
• Compare function 
• Code Envelope Check 

Step 1: Find Duplicate Items 
Open up the items window to see all items: 

 

On the Tools menu choose Find -> Identical Items… 
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This will bring up Find Items window to help you find identical items: 

 

The combination of weight group and item number has to be unique in ShipWeight, so you are not 
allowed to enter any items with the same combination of weight group and item number. So, that is 
the first way to prevent duplicate items going into the database. 

There can be errors that make duplicate items going into different items number and different 
weight groups, so you can use this tool to detect those. 

Firstly, the user checks the boxes next to the Compare Field. For example if we want to find any 
items in the database that share same Description and Weight: 
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Then click the Query button, the window is going to search through the database: 

 

On the right side we can see several instances with items that share the same Description and 
Weight: 

 

And if we click on the first one, then we get the details under: 
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The detail shows that weight group E3.3.1 contains two items (00214 and 00217) with the same 
Description and Weight. 

Step 2: Check for Extreme Values 
Another typical mistake is entering in wrong CG or Weight, by for example putting in mm instead of 
meters, or somehow else getting some extreme value. 

The easiesnt way to check is by going into the Items window, make sure you are listing all items: 

 

Then go to the Table View, and click on the headers to sort. For example, go to TCG column and click 
once on the header. It’s going to start with the lowest TCG value  

-11.4: 
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If we click again, the largest value will be the first one displayed: 

 

So, here is a typical mistake, when someone entered millimeters instead of meters. 

So it is very easy to find the extreme values, by clicking on the header. 

Now we can just go and correct the value, by putting the decimal: 
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And we can also do the same procedure to check the LCG and VCG. 

We can notice the VCG value is also not introduced correct, and we will show you another way to 
find the extreme values. 

 

Another way to discover errors is to compare on the weight group level.  

Close the items window. 
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Step 3: Compare Projects at Weight Group Level 

 

This brings up the Compare window: 

 

Which will show the Weight, VCG, LCG and TCG. It is sorted by hierarchy, and you can add previous 
revisions or previous projects in the upper right area, and compare values on the weight group level. 

To add more projects, right click in the Project area and select Set Project Database…: 
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The Open SQL project window will open. For example, SW00_DB_Space database and TestSpace 
Space_test project ID: 

 

Then click OK. 

Now it will show the values for the weights and center of gravity for the current project compared 
with the weights and center of gravity values for the selected project: 
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By default is sorted by Absolute deviation, and obviously if you list all the hierarchy, then the 
agregated weight groups to top weight groups will come up on the top of the column. 

To avoid this, go to List and select Input: 

 

 

We can also sort by Relative deviation, to show which group has the largest relative deviation. 

All the information can be copied with Copy Table option and paste it to excel: 
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We can also print the table to make the report, by using the Print option.  

You can also shift from the Grid View to the Tree view, which will show you the weight groups in a 
hierarchy tree. 

 

Step 4: Run a Code Definition Envelope Check 
If you have defined a custom code, for example for area: 

 

And this custom code C05 has sub areas A1, A2 and A3 (these areas have been given box limits): 
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Press Close.  

Now in the items window, Items have been tagged to various areas: 

 

And we can check the correctness of these by going to menu View and Code Envelopes. This brings 
up the Code envelopes window: 
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This will show the custom code. If we select Show all option, the boundaries of the boxes will be 
displayed.  

 

 

Now check the Box label option and by clicking in A1, A2 or A3 row, various boxes will be highlighed: 
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If we highlight A2 and also check the box in front of A2, all items tagged to A2 will be printed in the 
XZ-plane and XY-plane: 

 

We see if all of the items are inside the box. We see one item outside the box: 
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The item number is 39, so we can scrolll down to Pos. 39 and find item 39: 

 

And obviously this is an error, so either item 39 has wrong CoG value or it has been tagged to the 
wrong area code.  

You can also print out the report for this using Print command.  

Step 4: Check the Report Setup Window 
From the Project menu, select Report setup. Select:  

Weight Groups      Defined  

Parameter sort       Unit  

Wgt.grp.                Sum  
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Code type              C01 – Drawing no 

 

Click OK to close the window. 

Step 5: Run a Standard Report 
Select Reports and 4 Weight and CoG wgt.grp. summary on the Project menu. The following 
window will open – just press OK 

 

The report will then be opened in the Print Preview window. In the Print Preview window, press the 
MS Word button to export the report. Close the Preview window. 
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Step 6: Run a Crystal Report 
Start ShipWeight Report by selecting Crystal Reports… on the Project menu of ShipWeight. 



121 
 

 

The first thing to do is to select the report you want to run. In this example we will use the report 
Three-digit sample.rpt. Locate the report file on your hard drive by pressing the Browse button to 
open the Open window window.  

When you have located and selected the file Three-digit sample.rpt, press open. Now the file name 
will show in the Select report field.  

Next, press the ‘Run report’ button. 

In the “Enter project ID” window that now pops up, select “Tutorial” from the dropdown list and 
click “OK”. 
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The report should now be displayed after a few seconds. 

 

Now, use the toolbar or the group tree to navigate through the report. Also try exporting the report 
to portable document format (PDF), Word or Excel.  
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Playground Area 
This section will show how to 

• Set up a Playground Area (sandbox environment) 
• Use Playground Area as a net change and approval tool 

Step1: Create (or select existing) Code for Worksets (or use Weight Groups) 
To set up a successful playground area first we have to select a custom code that will work as our 
work packages or that will group the items that we need to check in and out of the playground area. 

Go to the View menu and select Code Definition…  

 

The Code Definition window will open: 

 

Within the code definition window we could have selected any of the existing codes to be used as 
our playground area codes: 
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or we can define our own code, specific playground area code: 

 

Now we need to add few subcodes for the work package so that we can use to group items to check 
them in and out of the playground area. Select the new code C04 – Work Package: 

 

 

 

And add the following subcodes: 
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So, basically we have the code to groups the items that need to be checked in and out of the 
playground area. 

In principle, any code may work as a workset code (drawing number, CAD package, department 
number, etc…) 

Now Close the Code Definition window.  

Step 2: Enable the “Playground” in the Option window 
Go to the View menu and select Options… 

 

The Options window will pop up: 
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Now, enable the workset, by checking the Use Worksets box, and select C04 – Work Package code: 

 

Below there are some Comment Labels which can be freely edited. 

 

Step 3: Define Margins 
Finally, in the Options window are the margins, in the lower right corner. These margins can be set 
and defined in the Margins window. To open the Margins window, press the browse button: 
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The margins window pops up: 

 

 

 

Define the following margins: 
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Click Close. 

So, now we have defined the Workset to start working with the Playground: 

 

 

Step 4: Choose a background color for the Playground item window! 
The last thing is to select the Playground Color. To do this, from the Options window, go to Layout 
tab and click the Browse button: 



129 
 

 

The Color window will appear: 

 

 

 

Choose the background color: 
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Press Add to Custom Colors and click OK. 

 

This was done to distinguish the difference between the live database and the playground area 
database. 

Click OK to close the Options window. 

 

Step 5: Open the Item Playground Window 
From ShipWeight main menu -> Items -> List Playground Items -> All… 
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The Item Playground window opens: 

 

The playground window got the blue background, so we clearly can see this is working in the 
playground and not in the live database (the Items window). 

So, currently there are no items in the playground window. Now we have to check some items into 
the playground. Close the Playground window for now. 

Step 6: Assign items to a workset and check out the workset 
To do this we need to select items in the live database, mark them with the work package and check 
them out. So, open up the live database: 
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The Work Package column should already be visible in the Table view area. If it is not visible, then it 
means it is hidden and needs to be moved from Hidden to Codes in the Item Settings window. So, 
open the Items Settings window from Setting menu -> Item Settings… and expand the single and 
table view Hidden folders: 

 

Because C04 – Work Package is hidden, we need to drag and move it to Codes folder: 
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Now press Close. You will notice that the Work Package column has been added in the Table View: 

 

Select all of the items in group E4 using Ctrl A  
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and go to Items menu and select Set Field Values… 

 

The Select field type window will open: 
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Select C04 – Work Package: 

 

And then press OK. 

The Select code window will appear: 

 

Assign all of this to W3 code to group the items: 
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And press OK. 

Now, if we scroll to the right, we can see the work package, we have W3 for all items from E4 group, 
and they are still in the live database: 

 

To get these items into the playground area, we need to check them out.  

Go to Items menu and select Worksets… 

The Worksets window opens: 
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Now to check out the items market with W3, in the Worksets window select W3 and press the Check 
Out button:  

 

The following message will be displayed: 

 

Click OK. Now we can see we have a new line with a red arrow which indicates that items with W3 
have been checked out: 
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Close the Worksets window. 

 

These items are still existing in the live database (Items window), but also a copy of them have been 
moved into the Playground area.  

 

 

 

 

Step 7: Make your changes to the weights in the playground area! 
For example delete one item, by using right click and Delete option: 
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You will be asked the following: 

 

And click Yes. 

 

You can also change the UnitWeight for one item, for example: 
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For item no 00370 instead of 430 for UnitWeight, type for example 1000: 

 

 

Or add a new item: 
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After we added the new item, we also need to assign it to the work package. So go the Test item 
line, to Work Package column and select from the list W3: 

 

Close the Item Playground window and save. 
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Step 8: Validate the change in the net change window! 
Now we can go and check in the net changes. Go to Items menu, then Worksets… 

 

Click on the red arrow, which represents the items that we checked out and click the Review button.  
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Once Review button has been clicked, the Workset Review, Approve & Check In window will 
appear: 

 

In this window we can see the net changes that have been done to the workset.  

In the upper level, it can be noticed the User ID detail, who checked the workset out, and the date, 
also who is the last person that changed it.  

Also, the net overall changes can be seen here: 
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Also the detail changes, under the overall changes: 

 

From the detail changes, we can see a new item (Test) has been added. The green circle means it is a 
new item. 

Orange circle indicates that the item had some changes to it. 

The red circle means that the item has been removed. 

Finally, the net change of all these items is shown here, in the orange line: 

 

Step 9: Review, Accept (or Reject) change 
Now to approve this click Review OK.  

If the results are not satisfactory click Reject. 

If we click Review OK, and close the window, we will see the arrow changed from red to orange, 
meaning that this has now been reviewed ok, but it has not yet been checked in.  
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So, no changes has currently been done to the live database. To make the changes effective to the 
live database, select the orange arrow and click Checkin button: 

 

And the Workset Review, Approve & Check In window will open: 

 

Step 10: Approve and Check In Workset 
Give an approved comment: 
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Net change must be assigned to a margin: 

 

Then select Approve & Check In button. 40 items checked in: 
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And the orange arrow become green: 

 

Now close the workset window. Then open the Playground area. It is empty, the items have been 
checked in. 

And the live database has been updated with the changes done in the playground area.  
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Parametric Estimation 
This session will give an introduction to the parametric estimation in ShiPWeight 

Step 1: Start ShipWeight and Log on 

  

Start ShipWeight and log in to ShipWeight using the user name “Administrator” and password 
“admin”. 
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Step 2: Start a New Project 

 

When ShipWeight opens, click the “New” button on the toolbar and select “ProjectDB” as Database 
ID, set “Tutorial” as Project ID, and select Main Type “Offshore Vessel” and sub type “Anchor 
Handling Tug”.  You may also give in a vessel name if you’d like, but this is not necessary.  Hit the 
“OK” button. 
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Step 3: Enter Ship Parameters 

 

In the “Main Parameter” window that shows up, give in at least the parameters as shown above.  
You may give in other parameters as well if you like. 
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Step 4: Select the Demo Ship Historical Database 

 

Next, go to the View menu and select the “Options…” window.  Click the “Database” tabsheet in the 
Options window, and select the “Browse” […] button next to the “Path Historical Database”.  In the 
pop-up window from the browse, select the “sdb_Demo” database in the list and hit the “OK” 
button.  Next, hit the “OK” button on the Options window. 
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Step 5: Activate the Demo Ships in Reference Project Window 

 

Next, head to the “Estimate” menu and select “Reference Projects…” window.  In this window, selec 
the “Include all” button and hit “OK” button.  This activates all the reference projects that in the 
demo database that was selected in previous step.  We now have a basis ready for the parametric 
estimation. 
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Step 6: Select the Lightship Weight Group and Open the Estimation Window 

 

Select the “LW – Ligthship” group in the main window WBS and clikc the estimation graph button in 
the toolbar to open the estimation window.  We are now ready to estimate the Ligthship. 
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Step 7: Estimate Lightship Weight 

 

In the graph window, select the “Regression” radiobutton to execute an estimation based upon 
selecting a coefficient for the method from the regression line.  Next, click the “Save” button to save 
your initial Lightship estimate. 
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Step 8: Estimate Lightship VCG 

 

Go to the “Estimate” menu in the Estimation window and select “VCG” to start estimating the initial 
LightShip VCG value.  Selct the “Regression” radiobutton to estimate the VCG value for the lightship 
and hit the “Save” button on the toolbar to save. 
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Step 9: Estimate Lightship LCG 

 

Repeat the same steps as above, but now for selecting the LCG instead of VCG, and after this, close 
the window by clicking the Close (Door) button on the toolbar. 
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Step 10: Lock Lightship Estimate and Select Subgroup 

 

You should now see the results of the Lightship estimation in the main window.  Click the Lock (key) 
button on the right end of the toolbar to lock the estimated numbers before we go refine the 
estimate.  Next, select the “Equipment” weight groups in the main window and once again click the 
graph icon on the toolbar to open the Estimation window. 

Step 11: Estimate Weight of Equipment Group 
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Repeat the steps from the Lightship estimation: Select the “Regression” radiobutton to execute an 
estimation based upon selecting a coefficient for the method from the regression line.  Next, click 
the “Save” button. 

Step 12: Estimate VCG of Equipment Group 

 

Repeat the steps from the Ligthship VCG estimation:  Go to the “Estimate” menu in the Estimation 
window and select “VCG” to start estimating the initial Equipment VCG value.  Select the 
“Regression” radiobutton to estimate the VCG value for the equipment and hit the “Save” button on 
the toolbar to save. 
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Step 13: Estimate LCG of Equipment Group 

 

Repeat the steps from the Ligthship LCG estimation:  Go to the “Estimate” menu in the Estimation 
window and select “LCG” to start estimating the initial Equipment LCG value.  Select the 
“Regression” radiobutton to estimate the LCG value for the equipment and hit the “Save” button on 
the toolbar to save. 

Step 14: Move to Hull Group 

 

Click the toolbar button with the right arrow as marked above to move to the next weight group on 
the same level (Hull) without closing the estimation Window. 
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Step 15: Change Weight Estimation Formula for Hull 

 

In the Hull weight group the standard formula is using the Watson E-parameter.  We do not have the 
details at hand to fill this in, so instead we will change formula.  Go to the “Method” menu and 
select Main Parameter as the method to use instead of the Default method.  The method will now 
change to a formula only containing the main parameters and we do not have to enter more 
information to carry out the estimation. 

Step 16: Estimate the Hull Weight 

 

Now estimate the Hull weight by selecting the “Regression” radiobutton and save the result. 
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Step 16: Estimate the Hull VCG 

 

Next, switch to VCG estimation from the Estimate menu and carry out this estimation by again 
selecting the ”Regression” coefficient and finally again save the result. 
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Step 17: Estimate the Hull LCG 

 

Repeat the steps you just did for the VCG estimation, only this time for the LCG. 

Step 18: Move to Machinery Group 

 

Click the toolbar button with the right arrow as marked above to move to the final weight group on 
the same level (Machinery) without closing the estimation Window. 
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Step 19: Set Power Range Limit to Filter Projects 

 

In the Machinery group, click the hyperlink next to the “Main engine power” parameter and in the 
pop-up window, set 15000 as maximum power and 8000 as minimum power as range for the 
propulsion data to be plotted in the graph.  Hit OK button to close window. 
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Step 20: Estimate Machinery Weight 

 

Check the checkbox to the left of the hyperlink where you just set the range for Main engine power 
to activate this as a filter for the projects plotted in the graph.  Click the “Average” radiobutton to 
select the coefficient to be used in the estimation and to calculate the Machinery weight. Save the 
result. 



165 
 

Step 21: Estimate Machinery VCG 

 

 

Go to the “Estimate” menu and carry out the estimation for the VCG by selecting again the 
“Average” coefficient.  Save the result. 
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Step 22: Estimate Machinery LCG 

 

Carry out LCG estimation in similar fashion as for VCG, but in addition, after saving, close the 
Estimation window by clicking the Close button (door) in the toolbar. 
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Step 23: Check Results from Subgroups 

 

You should now see the results of your estimation of the sublevels.  However, not the value in the 
“Remainder” group as this automatically gets the deviation between your initial  estimation and the 
sum of the sublevel group estimations.  This is because you locked the results after the Lightship 
estimate. 

Step 24: Remove the Remainder Value  

 

Unlock the results and delete the Remainder value by clicking on the Remainder weight grid to get it 
to edit modus and delete the weight value.  The results of the Lightship will after this become the 
sum of the subgroups. 
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Step 25: Select Your Company Logo for Reports 

 

Go to the View menu and open the Options window.  Select the “Report” tabsheet and click the 
browse button […] to select a company logo file.  Hit the OK button. 
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Step 26: Print a Result Report 

 

Go to the Project menu, select submenu Reports and select submenu item for report number 9 – 
“Methods and Coefficients” to produce a report of the estimation you have just finished. 
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Step 27: Print a Detailed Report 

 

To produce more background information about a specific estimation, select the weight group in the 
main window, open the estimation window from the toolbar and click the “Print” button.   This will 
produce a more detailed report for the estimation of a particular weight group. 
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Some Additional Parametric Estimation Topics 
On the menu Estimate, click Define Methods…  

 

The Method Definition window window will show up: 

 

 

The area to the left contains the Default parameters. Select Main Parameter as Default. 

The area in the middle contains the work breakdown structure. In this area, use the mouse to select 
the weight group Hull.  

The method for this weight group will be shown in the area to the right.   
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You want the method for Hull to be W=k*Lpp*B*D and plot the coefficient against ship length. 
Select the estimation parameters and click once more, to reveal a combo box. Select – on top of the 
list to clear the parameter.  

Select the plot parameter and delete it. Leave the comparison parameters as they are. Under 
ESTIMATION, select a "length parameter" (e.g. Length betw. perp) in the combo box for No.1. Add 
breadth and depth parameters in same way (e.g. Ship breadth and Depth upperm. cont. deck). Set 
the Power parameters to be 1, 1 and 1.  

Under PLOT, select the "length parameter" again in the right area and click ADD button. Now you are 
done, select the OK button.  

To be able to use your own method do the following: Enter the main estimation window window in 
the weight group H Hull. From the menu Method select User defined. Now your own method will be 
applied when estimating. 
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Loading Conditions, Hydrostatics & Global Filters 
This section will look into: 

• Defining loading conditions 
• Calculating hydrostatics 
• Using global filters 

Step 1: Open the Loading Condition Window 
To start the Loading conditions window, go to View menu and select Load Conditions… 

 

The Load Conditions window will appear: 

 

Step 2: Get the Hydrostatics Table into ShipWeight: 
To get the hydrostatics table into ShipWeight, press the Hydrostatics button and this brings up the 
Hydrostatics window: 
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We can input all the needed values or Copy them from Excel (taken from the stability software): 

 

And then Paste them in the Hydrostatics window: 
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And press Close. 

Step 3: Create the Lightship Loading Condition 
The Loading Conditions are created in the Load Cases area, where each row will define one loading 
case. Let’s start by creating the Lightship condition. Type LW for LoadCase, then Lightship for 
Description. As always in ShipWeight when you create a new row, go to the row below to make sure 
this data has been properly registered in the database, then go back to the first row: 
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The definition of the lightship condition is done in the Weights area, and since is the lightship only, is 
just one weight to be defined: 

 

 

And select LW for Source column: 
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So, we are refering to the weight group Lightship in ShipWeight main window: 

 

 

Then right click and select Update Item(s) option: 
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And now it brings in the numbers of the weight and cg of the lightship, and also calculates the values 
for the Hydrostatics on the right side of the window: 
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Step 4: Create a Capacity Loading Condition 

 

And the Lightship and C-loads weights: 

 

 

Again, select both lines from Weights area, right click and Update Item(s): 
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This brings in the numbers of the weight and cg of the lightship, and also calculates the values for 
the Hydrostatics on the right side of the window: 
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Step 5: Create a Full Load Condition 
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The links that we create to ShipWeight, they are not live, so we need to select these items and right 
click and Update Item(s) manually every time: 
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Now we have created 3 loading cases, and have the hydrostatics values calculated for all 3 of them. 
All of the loading cases have one line each, but of course more weights can be added for each 
loading condition. 

 

 

Another way to create loading conditions is just refering to weight groups in the main hierarchy. 
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Step 6: Define a Ballast Condition 

 

We will not refer to any weight groups, we will only define the lightship weight in ShipWeight: 

 

 

But, now instead creating another reference to the ShipWeight weight groups, we will create a 
reference to the tank load: 
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So, T1 doesn’t have a Source because is just a load point. 

And one more point load T2 needs to be defined: 

 

Select all weight groups, right click and Update Item(s): 
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The hydrostatics values are calculated: 
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The last loading condition to be shown allows you to refer tanks that have specific contents and 
sounding and then it will fill up those tanks by using sounding tables. 

To be able to do that, in adition to add the Hydrostatics table, you also need to add tanks. So, if we 
click on the Tanks button, the Tank Definition window will open: 

 

We can see the prefilled list of tanks: 
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If we select one TankID, we will see for this specific tank, the sounding table, which allows to fill the 
tank for a certain percentage: 

 

Close the Tank definition window and define a new loading condition ARRIVAL and the 
corresponding weights: 
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R00001 line is connected to the Tanks list (window), which again is connected to sounding table: 

 

 

 

Right click on R00001 and select Fill Tank… 
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And for example, use 50% fill: 

 

Press OK. And then, ShipWeight looks up for the sounding table of this tank R00001, and gives the 
correct CoG and Weight: 
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Finally, select these rows again and Update Item(s): 

 

 

The arrival condition is updated and the hydrostatic values as well: 
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Values for the free surface moments can be given in directly either in the grid here: 

 

Or may be defined in the sounding table in the Tank Definition table: 
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As you can see now GM_corr –Free surface correction is 0: 

 

 

 

 

But if you type in for FSM-X, FSM-Y some numbers: 
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You will notice the free surface correction value has changed: 

 

Finally, one very important note, is that all the information from loading conditions window is taking 
basis in the fact that the origin is AP, baseline and centerline for the calculations. 

If you are using a project with the origin in FP and positive axis going from FP toward AP, to get 
correct hydrostatic values calculated. 

IMPORTANT: 

If your project is defined with origin in FP (FP=0) and positive direction from FP towards AP, make 
project settings as shown here: 

LCG set to Lpp value  
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LCG dir. Set to -1 

So, in the Project Info window: 

 

Change the LPP value, in this case LCG from 0 to 80, and then shift coordinate direction from 1 to -1: 
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If you do an FP =0 and positive from FP to AP, make sure you make this changes to have the 
hydrostatics calculated correctly, otherwise drafts at fore and aft and trim values will be wrong.  
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Step 8: Alternative Method: Using Global Filter for Handling Loading Conditions 
This chapter will explain how to hadle different loading conditions in the main window in 
ShipWeight. In the following project we have defined Lightship with margin items and Loads items, 
which together make up the total Displacement for the project: 

 

Now, if we expand the Lightship, we can notice this is made up by the typical summary of the 1 
through 700 digit SWBS numbers: 

  

If we expand the load group, we will see that the load is made up by summarising A loads, C loads 
and F loads: 
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This is just a summary of all loading conditions, and thus the total displacement in this case which is 
the summary of the Loads and the Lightship doesn’t make sense, it does not represents one 
particular loading condition. 

So, now we will apply global filters to set up various loading conditions, that would be meaningful, in 
the main window and also in running other functions in ShipWeight like weight distribution curve, 
gyradius function, and so forth. 

We will create loading conditions using the global filter. The global filter setting can be seen in the 
upper right side: 

 

 

Click the browse button (to the right of the Filter droplist). The Filter window will open:  
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Now we will create gloval filters for our various loading conditions. First we will create a lightship 
condition for the lightship weight. Start by giving a filter name, and create the actual filter as 
following: 

 

Global filter setup: 

(WgtGrp Not Like ‘[ACF]%’)  

meaning: SWBS groups should not start with A, C, or F 

 

Then press the Save button.  

In the window below we can see the global filter was created: 
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This filter means that we should not include weight groups that starts either with ACF and weight 
groups that starts with this having other letters or numbers after these letters (this is what the 
percentage % represents). 

Now, we will create a filter for the full load condition: 

  

And also define minimum load filter: 
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And finally the Capacity loads filter: 

 

 

 

 

So now, all the needed filters are created and available in the dropdown list: 



202 
 

 

Select from the list, the Lightship filter and then press OK. It will be visible in the Filter area: 

 

Starting with the lightship filter, it will remove all the other loads, and we are left only with the 
lightship: 
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Now if we pick from the filter’s list the Full load, it will show in the tree the lightship and also the full 
loads values: 

 

We can also check Minimum Load filter: 
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All the filters are global, meaing that they will be valid, not only for the main screen, but also for the 
item window, without the details, now we only see A Loads and Lightship items, and also when 
running weight distribution curve, gyradius, etc. then these functions in the ShipWeight application 
can now be run for these global filter settings. 

Step 9:  Running a Displacement Test Report 
In this chapter we will look at how to calculate a new lightship and center of gravity weight after a 
displacement and inclining test have been done. We will do this by setting up a project to hold 
temporary items and to distinguish between installed and uninstalled items and then we will use 
Crystal reports to calculate the lightship and center of gravity.  

Right now we are looking at a project and in this project we have already created some custom 
codes: 

 

And we called the needed custom code C06 installed: 
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The C06 code it is a listbox with two subcodes No and Yes: 

 

The naming of the custom code and the CodeID can be anything you choose. We need to have this 
custom code to distinguish wether an item is installed or not installed on the vessel.  

In the Items window these items are tagged in this way, so in this word there is nothing special 
about the code: 
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Another thing we need to do is to put all items that are on the vessel, but they are not part of the 
lightship weight, in other words they are temporary items that are onboard vessel during the 
displacement and inclining test, but should not be there during the delivery of the vessel and should 
not be included in the lightship weight. And these items, we have addded them to the temporary 
group: 

 

So the temporary group have now a list of items that will be taken off before the dlivery of the 
vessel: 
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Now go to Project menu and find Crystal Reports: 

 

To open up the crystal reports viewer: 

 

And here you press Browse button and find the Displacement and Incline test report.rpt  
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Then, you can simply press the Run report button: 

 

And then the Filter window opens up, to allow you to input some parameters: 

 

Fill in the parameters: 
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And more down below: 

 

Now click OK button and the report is running: 

 

And the report has at least two pages: 
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One summary page showing the weight and center of gravity: 

 

The next page starts to list the details of the weight of the items yet to be installed: 

 

And later on also the details of the items in the temporary groups. 

And then is the summary on the main page: 



211 
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Phase Codes 
This section will into doing weight tracking for series production of vehicles with configuration 
changes raises some challenges. Using Phase Codes 

Step 1: Define the Phase Code as Custom Code 
Open the code definition: 

 

The Code Definition window will open: 

 

 

Define a custom code as shown below: 
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Next, define the Code ID for the custom code as shown below: 

 

Step 2: Define the “Start” and “Stop” Entries for the Phases 
This is just like any normal custom code. But the special thing is that at the end of this table where 
we can define the codes we added two columns Start and Stop (which are the same values as in the 
previous example): 
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Now Close the Code Definition window. 

Step 3: Tag the Weight Items to the Phase Codes 
In the Items window, items will be tagged to the phase code in a normal way: 

 

 

You can anytime set a different phase for any item: 
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Now we have to do the “slicing”, menaing we have to filter out only the items relevant for the vessel 
we want to know the weight and CG of… 

Because right now the total displacement shows 2512 tonnes, will be the summary of all items, 
meaning the summary of all phases, which is not any particular vessel: 

 

 

Step 4. Define the Global Filters for the Phases 
To get the weight and center of gravity for a particular vessel, we need to apply a global filter for this 
one vessel.  

To be able to do that there is one thing we need to do first, to set in the options window (View -> 
Options), and go to the Report tab: 
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You will see that last option Use Phase Code. Check the box and select from the list C10 – Phase: 

 

And then press OK. 

Now we can set up a global filter for each individual vessel. And this is done in the global filter 
window: 
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Click the browse button to get the filter window: 

 

And in the global filter window, we can see we are able to define any type of filter.  

Give a Time, then a Filter Name, and then press the Save button:  



218 
 

 

Then click OK. 

Step 5: Activate the Global Settings for the Phase Code 
The filter will be activated and we will see that now in the main window the weight will be reduced 
from 2510 to 1934 tones. And this is the weight for vessel number 9. 

 

To change the vessel numer, press again on browse button and change the Time and Filter name: 
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Save and press OK. And now the weight and CG have changed based on vessel no. 5: 

 

Now we have two existing filters: 
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And we can change anytime between vessel no.5 and no.9. 

When we enable filters, is not only the CG from the main window that changes, but now everything 
in ShipWeight changes according to this filter. So, if we go to the Items window we will see items 
belonging only to vessel no. 5 if the filter is Vessel no 5. 

More on the Phase Code Concept 
Phase coding means looking at the series production as a timeline, where: 

• The timeline is starting with vessel 1 and ending at vessel n. 
• The user defines the necessary phases, ranging from any start and endpoint on the timeline 
• Weight items are tagged to a phase, meaning that they are to be included for vehicles in this 

phase 

The total weight of an individual vehicle is the sum of all items tagged to the phases that the time of 
the vehicle corresponds to. 

The advantages of the Phase Code Approach can be summaries in these points: 

• Items are only needed once (one row) in the database regardless of how many vehicles are 
in the production line 

• It is easy to deploy weight items to a range of vehicles, and to change the extent of the 
range 

• You can easily find the weight of an individual vehicle by slicing through the phases at the 
time of the vehicle 

• Same approach can be used for multiple phases of a single vehicle throughout its life-cycle 

Examples 
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Examples: 

Vessels: series of 10 monohull with modifications 

 

 

Aircrafts: aircraft series production  

Various configurations during production: 
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Offshore construction: lifecycle phases of an offshore construction 

 

 

Satelite: satelite phases 
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We consider the building of 20 vessels of the same class. Now this 20 vessels will not be completely 
identical, so we can not have them in only one project, but we can define phases containing the 
differences and use the phase codes to handle all 20 vessels still in one project. 

So, we imagine we have a timeline, representing the number of vessels, going from 0 to 20: 

 

 

Then we can imagine we have an initial phase (Phase 0), which defines all weight items that will 
belong to all 20 vessels. So Phase 0 will stretch from 0 to 20:  
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And then if there are modifications, or some special equipment that is valid for example only for the 
first vessels, then we define a new phase (Phase 1) for these vessels only: 

 

 

 

Another modification or change in design may happen at any time, so in this example we also have a 
Phase 2, going from vessel 2 to 10: 
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And another phase which indicates a modification or change, from vessel 6 to 16 (Phase 3): 

 

 

Phase 4 going from 4 to 20: 

 

 

And finally, the last phase (Phase 5) goes from 14 to 20: 
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We combine all of this weight items in one project, and tag items to the phases and then if we need 
to know the weight of for example vessel number 9, we slice through the database at vessel number 
9: 

 

And only add up the items that are tagged to phases or modifications that are valid for that vessel or 
that time. In this case we can see that slicing through phases at vessel number 9, indicates that we 
need to include items tagged with Phase 0, Phase 2, Phase 3, 4 and leave out Phase 1 and 5 for this 
vessel. 

Another way of representing this graph is to not use the bar, but just show the numbers for Start 
and End point. 
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Permission Settings 
When you log in into ShipWeight with the Administrator account you have access to all functions in 
ShipWeight: 

Within this administrator account in ShipWeight you can create other users and other user groups, 
where you can control the access these users will have to the various projects.  

 

Step 1: Open the Permissions Window for ShipWeight Accounts 
First, log on to ShipWeight with the ShipWeight Administrator User account. 

In the Project menu you will find a submenu called Permissions, then Administration and Change 
Password options.  

 

The Change Password option lets you change the password of the current user that you are logged in 
with, while the administration lets you create new users and user groups. So for now select the 
Administration option. The Permissions window will open: 

 

By default, ShipWeight “Administrator” user always exists, also Sysadmin group always exists. And 
the Administrator is a member of the Sysadmin group. 
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You can create as many users and users groups as you may want in ShipWeight, regardless the 
number of licences that you have. License only limits number of users simultaneous logged in, not 
the number of defined users (or number of client installations). In addition to create users and user 
groups, this Permissions window also has a tabsheet for Password Policy for the users: 

 

This policy applies for all users.  

Step 2: Create a New User 
To create a new user, go to the Users tabsheet and click New User button: 

 

Create new user window will pop up: 

 

Here you can define the user name (is the name that logs on into ShipWeight). Also fill in the Full 
Name, then select the User Group: 
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Click OK, and then we have to define the password: 

 

And click OK. So, now we have created a new user for the sysadmin group: 

  

This new user will have access to all functions in ShipWeight, including creating other users and user 
groups. These ShipWeight users what can be accessed within the executable application of 
ShipWeight, but is does not overwrite any permissions given to the windows users on the sql server, 
so the sql server defines what the user can do on the sql servers, and these ShipWeight user defines 
what can be accessed and granted permission within the executable application.  

Step 3: Define a New User Group 
Now let’s try to create another user group, a user group that should have only read only access. To 
do that, we click on the groups tab sheet and click the Add button: 
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And now we can define a new group: 

 

Give the Group ID and Description: 

 

Step 4:  Set Permissions for the New Usergroup  
Click on the Permissions tab. If you check all the options, then you will have access to the following: 
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Since we are going to do a read only group and we would like this user to be able to access all area 
of the project with Read permissions, we will just select Read on the WgtInfo, ProjectInfo, Setting, 
Estimation and Playground: 

 

Next step is to define which Weight group this user is allowed to look into. In this case we will allow 
the user to access all groups: 

 

The final tabsheet Codes, is to define if you want to remove access to certain custom codes for this 
group. 
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Now that the group has been defined, we can click OK and all these settings will be saved and we 
should be ready to add the user that we assign to this group.  

 

Step 5: Assign Users to the New Group 
Users then will inherit the permissions belonging to the group, we go to User tabsheet and we 
create a new user, by clicking New User button: 

 

Fill in the following settings: 
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And then click OK. And then we set a temporary password: 

 

Click OK, and then again OK. Now we have defined this new user. For neow, this user will have only 
read only access to this project. And we can test it by Exit ShipWeight. And then we open 
ShipWeight, and now we will not log in with the Administrator, but with Joe user name and 
password: 

 

And we are required to change the password at logon: 

 

So create a new password: 
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ShipWeight will open with the user permissions assigned. The user can read things, but he cannot 
change things. So the user can access the Items window, he can only read the information, he 
cannot change it: 

 

The setting for this user group, is now valid only for this particular project, so if we exit this project, 
and go back in as the Administrator again: 

 

So if we open now a different project, the new group that we created will not have access to the 
newly opened project, but the group will exist in the Permissions window. But if we check the 
Properties we will see for this project there are no permissions granted: 
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Permissions are granted only for the specific projects where you applied the permissions settings.  

More on Permission Settings 
This is the main settings explained in more details: 

Wgtinfo 

WgtInfo is permissions related to all weight 
information, like weight items and weight groups 

ProjectInfo 

ProjectInfo is permissions related to project 
parameters that is not a direct weight parameter, in 
example vessel length, frame spacing, machinery 
power etc. 

Setting 

Setting is permissions that is related to Item Settings 
(Item Window view setup), Custom Codes, Number 
of decimals and similar settings for the project 

Estimate 

Estimate is permissions related to the parametric 
estimation window. 

Playground 

Playground is permissions related to the Playground 
Area in ShipWeight 
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Subcategories: 
Each of the main category is divided into the following subcategories: 

Read 

When this is checked, the user/usergroup is granted access to read the information of the main 
category 

Edit 

When this is checked, the user/usergroup is granted access to edit the information of the main 
category, but only one item at the time. 

MultipleEdit 

When this is checked, the user/usergroup is granted access to edit the information of the main 
category, and several items at the time, in example deleting out all items within a weight group. 
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Output 

When this is checked, the user/usergroup is granted access to run reports of the information of the 
main category 

Import 

When this is checked, the user/usergroup is granted access to do file imports of the information of 
the main category 

Export 

When this is checked, the user/usergroup is granted access to do file export of the information of 
the main category 

 
In addition to granting the permissions to the actions 
as explained above, the user/usergroup must also be 
granted access to the weight groups by checking off 
the part of ther WBS tree that is relevant for the 
user/usergroup (usually the whole tree). 

This is done by clicking on the “Weight group” 
tabsheet next to the “Permission tabsheet. 

 

See next pages for sample setups. 
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Examples    
Administrator         

Should be assigned to the default “sysadmin” user group.  No further settings needed 

Key User     

Should be assigned to the default “sysadmin” user group.  No further settings needed in ShipWeight.  
On the SQL Server, the windows user of this person may be restricted from administrative SQL rights 
at the server level. 

Weight Engineer   

Grant all permissions – check all boxes 
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User                            (playground only) 

Grant all permissions under Playground, Read Only on the rest 
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Guest                          (just look, no touch) 

Grant Read Only on all categories 

 

 

 

ShipWeight Plugins 
The Naviswork Plugin 
 



241 
 

Crystal Reports 
Introduction to Crystal Reports 

There are two ways of reporting from ShipWeight: by using the standard reports and Crystal 
Reports. 

The standard reports includes a Weight Item report, a Code report, a Weight Distribution report and 
a Weight tracking report to mention some. They are easily accessible from ShipWeight. 

The standard reports are built into – or “hardcoded” into ShipWeight. This means that they are 
included in the Shipweight-executable file. Therefore, a ShipWeight user cannot do any changes to 
these reports. The layout and the information to be included are locked. 

Naturally, many ShipWeight users need custom made reports. To meet this need, ShipWeight 
includes a powerful reporting engine based on Crystal Reports. Crystal Reports by Business Objects is 
the industry leading report-software created.  

ShipWeight includes a Crystal Reports viewer. Basically, the ShipWeight Reports window does three 
things: 

1. reads a predefined report formatting file 
2. extracts data from the current database 
3. displays the report on screen 

 

Once your report is displayed on screen, you can send the report to a printer or export the report to 
various file formats. This includes formats such as Microsoft Word DOC and RTF and Adobe PDF. 

ShipWeight only comes with the viewer part of Crystal Reports. To be able to create your own 
reports, you must purchase the full version of Crystal Reports. 

The full version of Crystal Reports is a powerful, yet easy-to-use, tool for designing reports. Using 
Crystal Reports, you set up a report template specifying: 

1. what data the report should contain 
2. the order the data should appear 
3. the format of the report 

You can easily insert graphics, such as your company logo, into the report. Also a variety of charts 
are available for use in your report. 

When you created a report template, you save it as a .RPT file. Make sure to set up Crystal Reports 
so that data are not saved with the report. This means that the .RPT file will not contain any data – 
only the formatting of the report. 

Now you can easily share your .RPT file with any ShipWeight user in your organization. Any user 
authorized to access the ShipWeight Report Viewer can run, view and print the report. 

 

The Crystal Reports main window includes two main parts: The ‘Field Explorer’ and the Design Area. 
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The Field Explorer includes all data that is available for use in the current report. This includes: 

• Database Fields  
• Formula Fields (calculated data) 
• Parameter Fields (user input) 
• Running Total Fields 
• Group Name Fields 
• Special Fields (page number, date etc.) 

The easiest way of adding data to the report, is to simply drag it from the ‘Field Explorer’ into the 
Report. 
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The design area at the right side is divided into several sections: 

• Report Header  First part of the report – For report title, chart, etc. 
• Page Header  Repeated on top of every page – For logo, date, etc. 
• Group Header  Repeated at the beginning of a group – For group title 
• Details   The main data of the report 
• Group Footer  Repeated at the end of a group – For group summary 
• Report Footer   Last part of the report – For report summary 
• Page Footer   Repeated at the bottom of every page 
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ShipWeight is delivered with a set of sample reports to be used with the Report Viewer. In many 
cases, the easiest way of creating your own report will be to modify one of the sample reports. This 
is especially useful if you just want to do minor changes such as inserting your company logo or 
change the formatting of a report. 

In this session, we will create a new report from scratch using the ‘Report Creation Wizard’. 

Step 1: Start a New Report Using the Wizard in Crystal Reports 
To start the wizard, you need to click the New Report button on the toolbar: 

 

 

 

 

  

Now, the ‘Report Creation Wizard’ will appear. This wizard will guide you through the process of 
creating a report. 
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The first step is to choose the data you want to report on. Basically, this means choosing the 
database and tables to use in the report. 

The Data window of the wizard contains a list of ‘Available Data Sources’ on the left side, and 
‘Selected Tables’ on the right side. 

In the list of ‘Available Data Sources’, you first expand the branch named ‘Create New Connection’. 
This is done either by clicking the small plus sign or by double-clicking it with the mouse. 

 

Next, you should expand the ‘OLE DB (ADO)’ branch. A new window-window titled OLE DB (ADO) will 
appear. This window is used to set up the connection to the database. 
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In the ‘Provider’- list, you should select ‘Microsoft OLE DB Provider for SQL Server’. Click the Next 
button to continue. 

Now you will be asked to provide the necessary information to log on to the data source. 

The first thing you need to do is to check the ‘Integrated Security’ button. When ‘Integrated 
security’ is selected, Crystal Reports will connect to the SQL database using your Window username 
and password. Now you will not need to enter the ‘User ID’ and ‘Password’. 

Next, you should enter the name of the SQL server in the ‘Server’ field. Make sure to ask your 
database administrator for the name of the server containing the ShipWeight databases. 

Now, select one of the available databases from the ‘Database’ dropdown list. Databases starting 
with SW0 are project databases. 
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Click the Finish button to close the ‘OLE DB’ window. 

Back in the wizard, you will now find the database in the ‘Data Sources’ tree. 

Double-click on the database name to expand the branch. Next, expand the ‘dbo’ branch. A list of 
the available tables will appear. 

Now you need to drag-and-drop the ‘ITEM’-table’ to the ‘Selected Tables’ list at the right side. 
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Click the Next button. 

The next step of the wizard is to choose the fields to display in the report. 

The wizard now shows two lists: ‘Available Fields’ and ‘Fields to Display’. The Available Fields list 
shows all the fields in the ITEM table. 

To include fields in the report, simply drag-and-drop them to the ‘Fields to Display’ list. 

You can re-arrange the order of the selected fields by simply dragging them to a new location in the 
‘Fields to Display’-list. 
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When you have selected the data you want in the report, click the Next button to continue to 
Grouping. 

If you want to group the data in the report, simply drag-and-drop this field from the ‘Available’-list 
to the ‘Group By’ list. 

In this example we will group on code C01, which is a Section code. 
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Click Next to go to the Summaries-part of the Wizard. 

To add summary information to the report, simply drag-and-drop the field to the ‘Summarized 
Fields’-list. 

All numerical fields in the report are automatically added to the ‘Summarized Fields’-list. 

Please note that the default type of summary is Sum. Make sure to change summary type for VCG, 
LCG and TCG from ‘Sum’ to ‘Weighted average with Weight’. 
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When you click the Next button, you come to the Group Sorting. We will not use group sorting in 
this example, so you should click the Next button once more to go to the Chart-section of the 
Wizard. 

We will include a Pie Chart showing the Weight of each section. Select Pie Chart. Optionally you can 
change the Chart title. 

Make sure the On change of field is set to ITEM.C01, which is our Section code in this example. Also 
check that Show summary is set to Sum of ITEM.Weight. 
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Click Next to go to Record Selection. You can use record selection to include only a part of the data 
from the database in the report. 

We will not be using record selection in this example. Click Next to continue to the last item in the 
wizard: Template. 

Crystal Reports comes with a set of predefined templates. You can use one of these to quickly 
change the look of your report. 
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Click the Finish button to exit the Report Creation Wizard. 

Step 2: Create a Project ID Filter 
Each project database can contain several projects. The report will now include data from all 
projects on the database. To list data from the current project only, it is necessary to insert a filter. 

First, we will insert a parameter field to prompt for the current project name. Click Parameter Fields 
in the Field Explorer with the right mouse button. If the Field Explorer is not present, get it from the 
View menu.  From the right-click menu, select New… 
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In the Create New Parameter window, enter ProjectID (1.) as the name of the parameter. 
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To add a dynamic list of values to the ProjectID parameter, select Dynamic (2.). You then click the 
Insert button (3.), and select ProjectID from the dropdown list. In the Parameters column, click on 
the text Click to create parameter (4.). The text will change to ProjectID. 

Click the OK button to close the Create New Parameter window. 

Now we are ready to create the data filter. This is done by creating a Record Selection formula. 
Choose Selection Formulas and then Record… on the Report menu. 

In the Report Fields list of the Formula editor, expand the database and the item table. Select the 
database field ProjectID with the mouse, and drag it into the formula text window. 

 

 

 

In the formula text window, type the sign of equality (1.) after the text {ITEM.ProjectID}.  

Select the parameter named ProjectID (marked with a question mark icon in the list) in the ‘Report 
Fields’ branch. Drag and drop it to the formula text window (2.). 



257 
 

 

 

The selection formula should look like this: 

{ITEM.ProjectID}={?ProjectID} 

Click the Save and close button. The report data will now be filtered to include the selected 
ProjectID only. 
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Step 3: Formatting the Report  

 

 

 

The preview shows that the report needs some formatting. 

Some of the fields are too short to display the number. The easiest way to fix this is to click on the 
field in the preview area and expand it using the mouse. 

The group summary fields are in the wrong position. Drag and drop them into place. 

To switch between preview and design mode, simply click the tab in the top left corner of the 
preview/design area. 

Step 4: Displaying Values in a Different Unit 
Next, we want to display the data in US-units. In the database, all data are stored in metric units.  

Since the database does not contain any data in US-units, you need to create a formula to convert 
the value from metric to US units. 
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To create a new formula, you can right-click the Formula Fields in the Field Explorer. Select New… 

Enter the name of the formula: ‘US Weight’. 

Now the Formula Editor will appear. 

In the Formula editor, you will find a list of the available fields. Expand the branch ‘Report Fields’. 
Drag-and-drop the field ‘ITEM.Weight’, into the formula editor. 

Finish the formula by entering the multiplication sign (asterisk) and the conversion factor. The 
formula to convert from kg to lb should be: 

{ITEM.Weight} * 2.20462262184877 

Click the Save and close button on the toolbar. 
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Back in the main window of Crystal Reports, you will find the new formula under ‘Formula fields’ in 
the ‘Field Explorer’. 

Before you insert the ‘US Weight’ field, you need to delete the original weight field from the report. 
Simply select the field in the design view, and click the Delete button. 

Now, you need to drag-and-drop the ‘US Weight’ formula into the Details section of the report. 
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Finally, you must change the summary fields to summarize the ‘US Weight’ formula instead of the 
‘Weight’ database-field. 

To do this, select the Group Summary field in the design view, and click on it with the right mouse 
button. Select Edit Summary from the dropdown menu. 

 

 

 

 

The ‘Edit Summary’-window pops up. Select US Weight in the Choose the field to summarize 
ListBox. Click OK to close the window. Repeat this for the Report Summary. 
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The report now shows the weight in pounds instead of kilograms. 

Step 5: Summarizing a Custom Code 
In the project we have used, Code C03 is the Vertical Moment. We would like to summarize the 
moments. 

Crystal Reports can only summarize numerical fields. And since ShipWeight stores the code values as 
strings, you cannot summarize code values directly. 

The solution is to create a formula that converts the string C03 into a numerical value. 

Create a new formula named ‘VMom’. In the Formula Editor drag-and-drop the field ITEM.C03 into 
the editor. 

To convert a string to a number, you need to use a Crystal-Reports function named TONUMBER(). 
The formula should look like this: 

tonumber({ITEM.C03}) 

 

 

 

 

Now, the formula ‘VMom’ is available in the ‘Field Explorer’. 

In the design area, select and delete the field ‘C03’. Then drag the formula ‘VMom’ into the report. 

To insert a summary of the Vertical Moment, choose Insert Summary from the Insert menu. 
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Now the Insert Summary window will appear. First, select ‘VMom’ in the ‘Choose the field to 
summarize’ list box. 

Then make sure the Calculate this summary option is set to ‘Sum’. 

Finally, set ‘Summary Location’ to ‘Grand Total (Report Footer)’ 

 

 

 

In the same way, insert a Group summary. Hint: in the ‘Insert Summary’ window, you will need to set 
the ‘Summary location’ to ‘Group #1: ITEM.C01 – A’ 

Now, you successfully have inserted a summary of code values into your report. Click the Preview 
tab to see the result. 
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Step 6: Set a WBS Filter Parameter if Using SWSystem Tables 
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Create a new selection parameter “SWBS” in the report

 

 

Add a selection formula to the record selection in a the main report (unless only subreports):
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